Node.js

  • 安装

    pacman -S nodejs npm python2
    
  • 调试

    npm install -g node-inspector
    node-debug app.js
    
  • 升级npm

    npm -v
    npm install -g [email protected]
    
  • 安装模块

    npm install <packageName>    安装package
    npm install <packageName> -S 安装并保存到package.json文件
    npm install <packageName> -D 安装并保存到package.json文件的devDependencies部分
    npm install <packageName> -f 强制重新安装
    npm install githubname/reponame 从Github上的项目源代码安装package
    npm update <packageName>     更新已安装模块
    npm rebuild node-sass        重新编译node-sass
    npm outdated                 检测当前安装的所有模块是否有更新
    npm dedupe                   重新计算依赖关系,优化模块的存放结构
    npm run                      列出在package.json文件中定义的脚本命令
    npm list -g --depth=0        列出全局安装的package
    
  • 卸载模块

    npm uninstall <packageName> -S 卸载并更新package.json文件
    
  • 使用国内的镜像服务

    npm config ls
    npm config set registry https://registry.npm.taobao.org
    npm config set registry https://registry.npmjs.com
    
  • Yarn

    packer -S yarn
    yarn init
    yarn info <package>
    yarn add <package>
    yarn add <package> --dev
    yarn add <package> --peer
    yarn add <package>@<version>
    yarn add <package>@<tag>
    yarn upgrade <package>
    yarn remove <package>
    yarn why <query>
    yarn outdated
    yarn upgrade
    yarn ls
    yarn global <add/list/remove/upgrade> <package>
    yarn
    yarn start
    yarn test
    yarn run <script>
    

npm中依赖版本号是 ^x.y.z,适配范围是找到最左侧的第一个非0位,只允许这一位右侧的版本号变动。比如:

  • ^1.2.3版本包括:>= 1.2.3 并且 < 2.0.0
  • ^0.2.3版本包括:>= 0.2.3 并且 < 0.3.0
  • ^0.0.3版本包括:>= 0.0.3 并且 < 0.0.4

results matching ""

    No results matching ""